FIXED: Polaris 3900 was lazy and tail did not sweep (2022)

3 years ago my old Polaris 280 had a number of problems, and on the advice of a pool maintenance company I bought a new Polaris 3900. However, I was never very happy with it because it was not "peppy" -- seemed to crawl around where the older model zipped -- and the tail never really swept at all, where on the 280 the tail had been very effective at brushing the walls and sweeping debris to the drain.

The thing was serviced by a maintenance company at the beginning of each season, but the problems just never got any better. This year the problems were noticeably worse, to the point where the corners of the pool were collecting dirt lines that never got swept away. However, the (new) pool company took a look and claimed that there was nothing wrong with the Polaris, and that this is just an underperforming model.

Last week I finally had some little free time so I decided to do some research into the problem. I found hundreds of owners complaining online of the same problems, but I didn't find anybody with a solution.

I counted the wheel rotations and found only 22 RPM where the expected speed is 32-34 rotations per minute for the large wheel (per the user manual). I disassembled the 3900 and did not find any obvious problems, so I called Zodiac.

The nice man at Zodiac told me to remove the flow restriction disk installed at the wall -- but of course there is no flow restriction disk installed. Then he told me my Polaris booster pump was not producing enough pressure or enough flow to drive the 3900. This was not a reasonable suggestion, because the pressure release valve at the wall was blowing off a LOT of water and the flow was more than sufficient to make the backup valve work perfectly. So I thanked the nice man and hung up the phone. I realized that I would have to solve this problem myself, so even though I was pretty sure the booster pump was putting out plenty of water at a high pressure, I decided to prove or disprove this definitively before looking inside the 3900 for some kind of subtle problem.

I learned from another nice person at Zodiac that the 3900 requires 8-10 Gallons per minute at a pressure of 32 - 34 PSI when measured at the end of the supply tubing (after the backup valve).

I went on Amazon and ordered a combination pressure and flow meter (built by Toro). It arrived in just 2 days even though it wasn't sold by Amazon directly. This is a light-duty meter intended for occasional use with a hose bibb. It has a hose faucet connector, so I cut one end off an old garden hose, screwed it onto the meter, and clamped the open end of the garden hose directly to the Polaris backup valve (the inside diameter was a perfect fit, but the screw-on tightener is designed for the thicker wall of the polaris hose, so I used a hose clamp to make sure it didn't blow off under high pressure).

I turned on the booster pump and closed the flow control knob completely, and found that my static pressure was 60PSI -- that's pretty high -- and when the flow control knob was opened enough to allow a flow rate of 8 GPM, the pressure was 34 PSI, which is exactly what the 3900 requires. Just for interest, I also checked the pressure before the backup valve, and found that the backup valve itself introduces a drop in pressure of about 5 PSI, presumably due to flow restriction from the internal mechanism.

With plenty of flow at the right pressure entering the "critter," the problem had to be in the 3900 itself.

I took it apart again and this time I went over everything with a fine tooth comb, and with the absolute conviction that the problem was somewhere inside the critter. Armed with those tools and a magnifying glass, I did in fact find several problems that had not been immediately obvious.

The first problem was that the tail flow control assembly had two O-rings installed where there should only be one. This actually prevented the flow regulator from down-regulating the flow to the tail, and also made it extremely difficult to turn the tail sweep control valve at all -- something I had noticed from day one. OK, one definite problem resolved, except that this fix still would not help me create *increased* tail sweep -- I would now be able to turn the sweep down, but I needed to turn it UP. I looked more closely at the mechanism of the sweep flow control. Basically, there are two plastic surfaces pushed against each other, each with a small half-circle cut out to allow water through. If the tail control is rotated so the two half-circles line up, the maximum amount of water comes through. If one piece is rotated 180 degrees, the two half circles will not overlap at all, and no water will come through.

I connected the tail assembly (with tail) to my flow measuring apparatus and turned up the pressure. The Polaris 3900 water management system delivers flow to six places: three cleaner siphon ports, the wheel drive, the balance jet, and the tail. But even when I gave the tail a full quarter of the total rated pressure, the water that came out was not up to the jet force and volume that I was used to seeing with the old Polaris 280. It seemed to me that the holes feeding the tail are just too small to allow enough flow through at the pressures being supplied. Therefore I decided to enlarge the two holes so that more water would come through when they were aligned. The alteration would mean that I could still turn down the flow, but I could no longer completely shut off water to the tail -- but why would I ever want that? I took a small file and enlarged the holes by about 30%. Instead of two half-circles, they now looked like slightly flattened footballs.

OK, the tail will get more water when turned to max open, and I can still turn it down most of the way if I need to. Now to debug the overall peppiness issue.

Since the wheel is driven by a jet of water that pushes a water-wheel, there had to be a loss of pressure somewhere in the circuit before that jet. I plugged all the holes in the lower water management system and blew into the device, and there were no leaks. I hooked up my flow pipe directly to the lower WMS to drive the jet directly, and -- wow -- the wheels turned like crazy when I put the rated pressure/flow into the WMS. I plugged the upper supply tube and blew air into it, and there were no leaks. That only left the connection between the upper supply tube and the lower WMS. This is an O-ring joint, and I inspected it closely with a lighted magnifier. Lo and behold, the slip joint itself is just a teensy bit loose, and (more importantly) the O- ring that was installed was not *quite* the correct size for the joint. The O-ring was just a little bit larger diameter than its intended seat, and also somewhat narrower than the bed it should have filled. Under magnification I could see areas where the O-ring had become crimped by being squeezed out of its bed. Just looking at it you would not be likely to think anything was wrong -- it hardly looked like enough to make any difference at all. Surely we couldn't be getting much loss of pressure through such a tiny gap? But of course we could.

I went to the hardware store and bought a correctly-sized O-ring and installed it. Then, since I happened to have the slightly over-size O-ring already in my hand, I slid it up inside the upper water supply tube to serve as a compression gasket between the lower water management system and the upper supply tube -- it snugged up in there very nicely, and even though it's not part of the original design, it can serve as a fail-safe in the event of leakage around the primary O-ring.

I did also put a little bit of stopcock grease on all of these surfaces (I have a tube left over from a chemistry lab I had back in 1976, and have found that the stuff works great in harsh marine environments).

Put everything back together, and fired it up, and got a big smile on my face as I watched the little critter go zipping around the pool, lashing its tail exactly the way I had been hoping. I swear, I felt peppier myself just watching it. And in fact my wife sat and watched it perform for about a half hour before she pulled herself away.

So bottom line: I think this thing probably came from the factory with the wrong size O-ring installed in the main water supply junction to the WMS, and with two O-rings instead of one in the tail valve assembly. For sure it came with the wrong size flow adjustment holes designed into the tail valve control mechanism. The original over-large O-ring worked semi-adequately when it was new -- it leaked enough to make the 3900 sluggish compared to other models, but not enough that it failed to clean the pool. Over a couple of years it got slightly extruded and a little bit stiff, and the leakage became worse to the point where the poor little guy was really anaemic and had low blood pressure!

If you have the same sluggishness problem I was experiencing, start by installing the right O-rings -- don't get a replacement for what's already in there, get one that really fits snugly and fills the ring bed. Then if you want more tail action, go ahead and file both half-moon holes a little larger (doing just one won't change anything). The tail modification works perfectly for me -- if I rotate the valve counter-clockwise the tail just lies there, and if I rotate it all the way clockwise it lashes like a live animal. I think Polaris ought to modify this part of their design, but TJMO FIXED: Polaris 3900 was lazy and tail did not sweep (1)

BTW, I also learned that there is an add-on tail tip available that will stop the tail from spraying water out of the pool when the critter climbs the wall and then dives back down. Recent models come with this already installed, but mine did not. At one time I might have wanted that feature, but after several years of lackadaisical tail droop, I'm kind of enjoying the occasional spritz, and the shrieks when somebody fully dressed gets unexpected attention from the critter FIXED: Polaris 3900 was lazy and tail did not sweep (2)

That's my story and I'm sticking to it.

Top Articles

You might also like

Latest Posts

Article information

Author: Duane Harber

Last Updated: 12/15/2022

Views: 5367

Rating: 4 / 5 (71 voted)

Reviews: 86% of readers found this page helpful

Author information

Name: Duane Harber

Birthday: 1999-10-17

Address: Apt. 404 9899 Magnolia Roads, Port Royceville, ID 78186

Phone: +186911129794335

Job: Human Hospitality Planner

Hobby: Listening to music, Orienteering, Knapping, Dance, Mountain biking, Fishing, Pottery

Introduction: My name is Duane Harber, I am a modern, clever, handsome, fair, agreeable, inexpensive, beautiful person who loves writing and wants to share my knowledge and understanding with you.